const regex = /((\"[^\"]*\")|[a-zA-Z]+)[,;]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\"[^\\"]*\\")|[a-zA-Z]+)[,;]', 'g')
const str = `coffee, water; tea
"coffee, black;", water; tea`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);