#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\"[^\"]*\")|[a-zA-Z]+)[,;]"
Local $sString = "coffee, water; tea" & @CRLF & _
""coffee, black;", water; tea"
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)