package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\"[^\"]*\")|[a-zA-Z]+)[,;]`)
var str = `coffee, water; tea
"coffee, black;", water; tea`
var substitution = "$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}