$re = '/((\"[^\"]*\")|[a-zA-Z]+)[,;]/';
$str = 'coffee, water; tea
"coffee, black;", water; tea';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;