re = /((\"[^\"]*\")|[a-zA-Z]+)[,;]/
str = 'coffee, water; tea
"coffee, black;", water; tea'
subst = '$1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result