use strict;
my $str = 'coffee, water; tea
"coffee, black;", water; tea';
my $regex = qr/((\"[^\"]*\")|[a-zA-Z]+)[,;]/p;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";