# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bjack.*?jill\b/Jack & Jill/gm;t' <<< "jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
"