using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bjack.*?jill\b";
string substitution = @"Jack & Jill";
string input = @"jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}