package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bjack.*?jill\b`)
var str = `jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
`
var substitution = "Jack & Jill"
fmt.Println(re.ReplaceAllString(str, substitution))
}