#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bjack.*?jill\b"
Local $sString = "jackjill" & @CRLF & _
"jack jill" & @CRLF & _
"jack-jill" & @CRLF & _
"jack&jill" & @CRLF & _
"jack & jill" & @CRLF & _
"jack-&-jill" & @CRLF & _
"jack and jill" & @CRLF & _
"jackandjill" & @CRLF & _
"jack-and-jill" & @CRLF & _
"jack n jill" & @CRLF & _
"jackandjill" & @CRLF & _
"jackandjilld" & @CRLF & _
"jacskandjill" & @CRLF & _
""
Local $sSubst = "Jack & Jill"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)