import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bjack.*?jill\\b";
final String string = "jackjill\n"
+ "jack jill\n"
+ "jack-jill\n"
+ "jack&jill\n"
+ "jack & jill\n"
+ "jack-&-jill\n"
+ "jack and jill\n"
+ "jackandjill\n"
+ "jack-and-jill\n"
+ "jack n jill\n"
+ "jackandjill\n"
+ "jackandjilld\n"
+ "jacskandjill\n";
final String subst = "Jack & Jill";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}