re = /\bjack.*?jill\b/m
str = 'jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
'
subst = 'Jack & Jill'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result