// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bjack.*?jill\b").unwrap();
let string = "jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
";
let substitution = "Jack & Jill";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}