$re = '/\bjack.*?jill\b/m';
$str = 'jackjill
jack jill
jack-jill
jack&jill
jack & jill
jack-&-jill
jack and jill
jackandjill
jack-and-jill
jack n jill
jackandjill
jackandjilld
jacskandjill
';
$subst = "Jack & Jill";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;