#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html"
Local $sString = "http://210.124.84.15/tji.html" & @CRLF & _
"http://210.124.84.15:8087/tji.html" & @CRLF & _
"http://210.84.15:8087/tji.html" & @CRLF & _
"http://210.124.84.15:8087/tji\.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")