import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "http:\\/\\/(?:[0-9]+?\\.){3}[0-9]+?\\:[0-9]+?\\/tji\\.html";
        final String string = "http://210.124.84.15/tji.html\n"
	 + "http://210.124.84.15:8087/tji.html\n"
	 + "http://210.84.15:8087/tji.html\n"
	 + "http://210.124.84.15:8087/tji\\.html";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}