using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html";
string input = @"http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}