package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html`)
var str = `http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}