// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html").unwrap();
let string = "http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\\.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}