const regex = /http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/(?:[0-9]+?\\.){3}[0-9]+?\\:[0-9]+?\\\/tji\\.html', 'g')
const str = `http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\\.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}