#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*:)(.*)(:.*)"
Local $sString = "123:12313@mail.com:hello" & @CRLF & _
"hello:12nj@randomwebsite.com:891"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)