$re = '/(.*:)(.*)(:.*)/m';
$str = '123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;