const regex = /(.*:)(.*)(:.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*:)(.*)(:.*)', 'gm')
const str = `123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);