using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*:)(.*)(:.*)";
string substitution = @"\2";
string input = @"123:12313@mail.com:hello
hello:12nj@randomwebsite.com:891";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}