#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[^\\"]*(?:\\.[^\\"]*)*""
Local $sString = "# COMMENT ONLY REGEX --> ;.+" & @CRLF & _
"1+2+3 ; this is my comment" & @CRLF & _
"2+3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# STRING ONLY REGEX --> "[^\\"]*(?:\\.[^\\"]*)*"" & @CRLF & _
"1+2+3+ this is a ";string;" "and another"" & @CRLF & _
"1+2+3 "another string"" & @CRLF & _
"" & @CRLF & _
"# COMBINED REGEX --> ?????????" & @CRLF & _
"(*1+2+"hello")+3 ; this is my comment" & @CRLF & _
"1+2+()*&^"*;;;"h;\";;;\"ello;" ; another comment" & @CRLF & _
"1+2+;"a comment ;;;" & @CRLF & _
"1+2+ "; \"" ";\"hello" ; comment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")