// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^\\"]*(?:\\.[^\\"]*)*""#).unwrap();
let string = "# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> \"[^\\\\\"]*(?:\\\\.[^\\\\\"]*)*\"
1+2+3+ this is a \";string;\" \"and another\"
1+2+3 \"another string\"
# COMBINED REGEX --> ?????????
(*1+2+\"hello\")+3 ; this is my comment
1+2+()*&^\"*;;;\"h;\\\";;;\\\"ello;\" ; another comment
1+2+;\"a comment ;;;
1+2+ \"; \\\"\" \";\\\"hello\" ; comment";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}