use strict;
my $str = '# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> "[^\\\\"]*(?:\\\\.[^\\\\"]*)*"
1+2+3+ this is a ";string;" "and another"
1+2+3 "another string"
# COMBINED REGEX --> ?????????
(*1+2+"hello")+3 ; this is my comment
1+2+()*&^"*;;;"h;\\";;;\\"ello;" ; another comment
1+2+;"a comment ;;;
1+2+ "; \\"" ";\\"hello" ; comment';
my $regex = qr/"[^\\"]*(?:\\.[^\\"]*)*"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}