using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^\\""]*(?:\\.[^\\""]*)*""";
string input = @"# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> ""[^\\""]*(?:\\.[^\\""]*)*""
1+2+3+ this is a "";string;"" ""and another""
1+2+3 ""another string""
# COMBINED REGEX --> ?????????
(*1+2+""hello"")+3 ; this is my comment
1+2+()*&^""*;;;""h;\"";;;\""ello;"" ; another comment
1+2+;""a comment ;;;
1+2+ ""; \"" "";\""hello"" ; comment";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}