import Foundation
let pattern = #""[^\\"]*(?:\\.[^\\"]*)*""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> "[^\\"]*(?:\\.[^\\"]*)*"
1+2+3+ this is a ";string;" "and another"
1+2+3 "another string"
# COMBINED REGEX --> ?????????
(*1+2+"hello")+3 ; this is my comment
1+2+()*&^"*;;;"h;\";;;\"ello;" ; another comment
1+2+;"a comment ;;;
1+2+ "; \"" ";\"hello" ; comment
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)