const regex = /"[^\\"]*(?:\\.[^\\"]*)*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^\\\\"]*(?:\\\\.[^\\\\"]*)*"', 'gm')
const str = `# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> "[^\\\\"]*(?:\\\\.[^\\\\"]*)*"
1+2+3+ this is a ";string;" "and another"
1+2+3 "another string"
# COMBINED REGEX --> ?????????
(*1+2+"hello")+3 ; this is my comment
1+2+()*&^"*;;;"h;\\";;;\\"ello;" ; another comment
1+2+;"a comment ;;;
1+2+ "; \\"" ";\\"hello" ; comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}