package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^\\"]*(?:\\.[^\\"]*)*"`)
var str = `# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> "[^\\"]*(?:\\.[^\\"]*)*"
1+2+3+ this is a ";string;" "and another"
1+2+3 "another string"
# COMBINED REGEX --> ?????????
(*1+2+"hello")+3 ; this is my comment
1+2+()*&^"*;;;"h;\";;;\"ello;" ; another comment
1+2+;"a comment ;;;
1+2+ "; \"" ";\"hello" ; comment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}