$re = '/"[^\\\\"]*(?:\\\\.[^\\\\"]*)*"/m';
$str = '# COMMENT ONLY REGEX --> ;.+
1+2+3 ; this is my comment
2+3
# STRING ONLY REGEX --> "[^\\\\"]*(?:\\\\.[^\\\\"]*)*"
1+2+3+ this is a ";string;" "and another"
1+2+3 "another string"
# COMBINED REGEX --> ?????????
(*1+2+"hello")+3 ; this is my comment
1+2+()*&^"*;;;"h;\\";;;\\"ello;" ; another comment
1+2+;"a comment ;;;
1+2+ "; \\"" ";\\"hello" ; comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);