# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![^,\r\n])(?=,|$)/0/gm;t' <<< "ABC,XYZ,LMN
0,,2.3
3.4,3,5
,0,
1.3,,4.5
-------------------------
ABC,XYZ,LMN
0,,2.3
3.4,3,5
,,0
1.3,,"