$re = '/(?<![^,\r\n])(?=,|$)/m';
$str = 'ABC,XYZ,LMN
0,,2.3
3.4,3,5
,0,
1.3,,4.5
-------------------------
ABC,XYZ,LMN
0,,2.3
3.4,3,5
,,0
1.3,,';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;