import re
regex = re.compile(r"(?<![^,\r\n])(?=,|$)", flags=re.MULTILINE)
test_str = ("ABC,XYZ,LMN\n"
"0,,2.3\n"
"3.4,3,5\n"
",0,\n"
"1.3,,4.5\n"
"-------------------------\n"
"ABC,XYZ,LMN\n"
"0,,2.3\n"
"3.4,3,5\n"
",,0\n"
"1.3,,")
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)