import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^,\\r\\n])(?=,|$)";
final String string = "ABC,XYZ,LMN\n"
+ "0,,2.3\n"
+ "3.4,3,5\n"
+ ",0,\n"
+ "1.3,,4.5\n"
+ "-------------------------\n"
+ "ABC,XYZ,LMN\n"
+ "0,,2.3\n"
+ "3.4,3,5\n"
+ ",,0\n"
+ "1.3,,";
final String subst = "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}