const regex = /(?<![^,\r\n])(?=,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![^,\\r\\n])(?=,|$)', 'gm')
const str = `ABC,XYZ,LMN
0,,2.3
3.4,3,5
,0,
1.3,,4.5
-------------------------
ABC,XYZ,LMN
0,,2.3
3.4,3,5
,,0
1.3,,`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);