using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^,\r\n])(?=,|$)";
string substitution = @"0";
string input = @"ABC,XYZ,LMN
0,,2.3
3.4,3,5
,0,
1.3,,4.5
-------------------------
ABC,XYZ,LMN
0,,2.3
3.4,3,5
,,0
1.3,,";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}