#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<![^,\r\n])(?=,|$)"
Local $sString = "ABC,XYZ,LMN" & @CRLF & _
"0,,2.3" & @CRLF & _
"3.4,3,5" & @CRLF & _
",0," & @CRLF & _
"1.3,,4.5" & @CRLF & _
"-------------------------" & @CRLF & _
"ABC,XYZ,LMN" & @CRLF & _
"0,,2.3" & @CRLF & _
"3.4,3,5" & @CRLF & _
",,0" & @CRLF & _
"1.3,,"
Local $sSubst = "0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)