use strict;
my $str = 'ABC,XYZ,LMN
0,,2.3
3.4,3,5
,0,
1.3,,4.5
-------------------------
ABC,XYZ,LMN
0,,2.3
3.4,3,5
,,0
1.3,,';
my $regex = qr/(?<![^,\r\n])(?=,|$)/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";