import re
regex = re.compile(r"(?:^\.+|(\.)\.+)", flags=re.MULTILINE)
test_str = ("543.210.987.654.321\n"
"43.210.987.654.321\n"
"987.654...321\n"
"87.654...321\n"
"7.654...321\n"
"654....321\n"
"54....321\n"
"4....321\n"
"....321\n"
"21\n"
"1\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)