re = /(?:^\.+|(\.)\.+)/m
str = '543.210.987.654.321
43.210.987.654.321
987.654...321
87.654...321
7.654...321
654....321
54....321
4....321
....321
21
1
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result