// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^\.+|(\.)\.+)").unwrap();
let string = "543.210.987.654.321
43.210.987.654.321
987.654...321
87.654...321
7.654...321
654....321
54....321
4....321
....321
21
1
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}