# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))/<span class="highlight">$1<\/span>/gi;t' <<< "You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
"