#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))"
Local $sString = "You Saved ₹ 1,71,252 in 7 days" & @CRLF & _
"Savings: 203 kW" & @CRLF & _
"Consumption: 225 kVAh" & @CRLF & _
""
Local $sSubst = "<span class="highlight">$1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)