package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))`)
var str = `You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
`
var substitution = "<span class="highlight">$1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}