use strict;
my $str = 'You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
';
my $regex = qr/(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))/ip;
my $subst = '<span class="highlight">$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";