re = /(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))/i
str = 'You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
'
subst = '<span class="highlight">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result