using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))";
string substitution = @"<span class=""highlight"">$1</span>";
string input = @"You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}