// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))").unwrap();
let string = "You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
";
let substitution = "<span class=\"highlight\">$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}